Tuesday, September 16, 2008

Offtopic - Zune new updates do not work on win2008 (Update: solution!)

Update with a solution to this below!

What's this? I was so happy that the zune software runs on my win2008 laptop, and now the new version refuses to install? bah!

Notice something strange - the "supported" only quotes 32bit operating systems, even though I downloaded and (tried to) installed the 64bit version.
It seems that Microsoft has the same problem that the software vendors have with supporting commercial software on servers.

It looks like I am doing a lot of hacking lately...like my hack to install the solution generator on 64bit machines, resolve this issue is done in a similar manner.
One caveat though -you have to uninstall the old Zune software before starting. In my case the settings were saved, but I do not gaurantee that will be the case for you.

  1. Download the zune v3 software from Microsoft, either 32bit or 64bit version - depends on what you are running.
  2. Using a decompressor like 7-zip, extract the file (right click the file, and choose extract to...)
  3. Go into the folder. It should have a sub folder called "Packages" and in there a file called "Zune-x64.msi" (I don't know what the 32bit one is called)
  4. Double click on that file. The installer may take a while, and at the end you have zune v3 installed on win 2008! (I didnt try to synch yet though - but it is playing music)

Another update - I tried upgrading the device and it failed. It only worked when I did it from my vista machine. So I guess this workaround isnt all that great - and comments below say that connecting to the market place also doesnt work (I cant comment on that because I do not live in the USA and dont have access to the market place)


Anonymous said...

I had the same problem today, even with 32bit Win2K8. It's rather frustrating since the previous update installed without a hitch.

Anonymous said...

I've tried everything to get Zune to install on my Server 2008 machine properly. I have tried everything from uninstall/reinstalls and rebooting in between, using the command line, winzip, winrar to extract the installer. Opening the installer in Orca and removing any installation os requirements. Everything installs fine. Zune launcher starts running. I have even synced about 20 games to the Zune via the XNA studio 3 beta. However, when I attempt to run the marketplace, Zune.exe starts in my task manager but nothing ever happends. I've left it up for hours, attached debuggers on to it. I went into the Zune install directory and edited the Zune.exe.config file to include debugging information. Nothing gets the marketplace up and running.

Any tips what so ever? Perhaps I should remove any entrieds with Zune in the name from my registry..? Do you happen to have any links to the 2.5 marketplace so I can analyze some of the install options to see if I can completely remove any trases of it?

Anonymous said...

Anyone else have this problem?